#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)[\p{L}\'\’\d][\p{L}\.\ \'\/\,\’\d-]*(*SKIP)(*FAIL)|."
Local $sString = "-" & @CRLF & _
"Random-morestuff" & @CRLF & _
"Random%morestuff" & @CRLF & _
"Rândôm"
Local $sSubst = "x"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)