import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\p{L}\\'\\’\\d][\\p{L}\\.\\ \\'\\/\\,\\’\\d-]*(*SKIP)(*FAIL)|.";
final String string = "-\n"
+ "Random-morestuff\n"
+ "Random%morestuff\n"
+ "Rândôm";
final String subst = "x";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}