const regex = /[\p{L}\'\’\d][\p{L}\.\ \'\/\,\’\d-]*(*SKIP)(*FAIL)|./gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\p{L}\\\'\\’\\d][\\p{L}\\.\\ \\\'\\\/\\,\\’\\d-]*(*SKIP)(*FAIL)|.', 'gu')
const str = `-
Random-morestuff
Random%morestuff
Rândôm`;
const subst = `x`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);