$re = '/[\p{L}\'\’\d][\p{L}\.\ \'\/\,\’\d-]*(*SKIP)(*FAIL)|./u';
$str = '-
Random-morestuff
Random%morestuff
Rândôm';
$subst = "x";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;