// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)[\p{L}\'\’\d][\p{L}\.\ \'\/\,\’\d-]*(*SKIP)(*FAIL)|.").unwrap();
let string = "-
Random-morestuff
Random%morestuff
Rândôm";
let substitution = "x";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}