re = /[\p{L}\'\’\d][\p{L}\.\ \'\/\,\’\d-]*(*SKIP)(*FAIL)|./
str = '-
Random-morestuff
Random%morestuff
Rândôm'
subst = 'x'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result