import re
regex = re.compile(r"[\p{L}\'\’\d][\p{L}\.\ \'\/\,\’\d-]*(*SKIP)(*FAIL)|.", flags=re.UNICODE)
test_str = ("-\n"
"Random-morestuff\n"
"Random%morestuff\n"
"Rândôm")
subst = "x"
result = regex.sub(subst, test_str)
if result:
print(result)