package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\p{L}\'\’\d][\p{L}\.\ \'\/\,\’\d-]*(*SKIP)(*FAIL)|.`)
var str = `-
Random-morestuff
Random%morestuff
Rândôm`
var substitution = "x"
fmt.Println(re.ReplaceAllString(str, substitution))
}