#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Za-z0-9] and made a stylistic change"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"Samples of what it should match: " & @CRLF & _
"**A and made a stylistic change** " & @CRLF & _
"**x and made a stylistic change** " & @CRLF & _
"**1 and made a stylistic change** " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"What it shouldn't match: " & @CRLF & _
"**A; and made a stylistic change** " & @CRLF & _
"**x; and made a stylistic change** " & @CRLF & _
"**1; and made a stylistic change** "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")