using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Za-z0-9] and made a stylistic change";
string input = @"
Samples of what it should match:
**A and made a stylistic change**
**x and made a stylistic change**
**1 and made a stylistic change**
What it shouldn't match:
**A; and made a stylistic change**
**x; and made a stylistic change**
**1; and made a stylistic change** ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}