import Foundation
let pattern = #"[A-Za-z0-9] and made a stylistic change"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Samples of what it should match:
**A and made a stylistic change**
**x and made a stylistic change**
**1 and made a stylistic change**
What it shouldn't match:
**A; and made a stylistic change**
**x; and made a stylistic change**
**1; and made a stylistic change**
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)