re = /[A-Za-z0-9] and made a stylistic change/m
str = '
Samples of what it should match:
**A and made a stylistic change**
**x and made a stylistic change**
**1 and made a stylistic change**
What it shouldn\'t match:
**A; and made a stylistic change**
**x; and made a stylistic change**
**1; and made a stylistic change** '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end