$re = '/[A-Za-z0-9] and made a stylistic change/m';
$str = '
Samples of what it should match:
**A and made a stylistic change**
**x and made a stylistic change**
**1 and made a stylistic change**
What it shouldn\'t match:
**A; and made a stylistic change**
**x; and made a stylistic change**
**1; and made a stylistic change** ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);