// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Za-z0-9] and made a stylistic change").unwrap();
let string = "
Samples of what it should match:
**A and made a stylistic change**
**x and made a stylistic change**
**1 and made a stylistic change**
What it shouldn't match:
**A; and made a stylistic change**
**x; and made a stylistic change**
**1; and made a stylistic change** ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}