import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Za-z0-9] and made a stylistic change";
final String string = "\n\n"
+ "Samples of what it should match: \n"
+ "**A and made a stylistic change** \n"
+ "**x and made a stylistic change** \n"
+ "**1 and made a stylistic change** \n\n\n"
+ "What it shouldn't match: \n"
+ "**A; and made a stylistic change** \n"
+ "**x; and made a stylistic change** \n"
+ "**1; and made a stylistic change** ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}