import re
regex = re.compile(r"[A-Za-z0-9] and made a stylistic change", flags=re.MULTILINE)
test_str = ("\n\n"
"Samples of what it should match: \n"
"**A and made a stylistic change** \n"
"**x and made a stylistic change** \n"
"**1 and made a stylistic change** \n\n\n"
"What it shouldn't match: \n"
"**A; and made a stylistic change** \n"
"**x; and made a stylistic change** \n"
"**1; and made a stylistic change** ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")