#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\w+ ){0,5}\w+@\w+\.(?:com|gov|edu|org)"
Local $sString = "please send your resumes to adsf@dsf.com apply now!" & @CRLF & _
"asdfa@asdf.com/adsf asdf" & @CRLF & _
"visit us at sfds@adfa" & @CRLF & _
"apply now" & @CRLF & _
"follow us on asdf@asdf.gov" & @CRLF & _
"asdfa.gov" & @CRLF & _
".com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")