using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\w+ ){0,5}\w+@\w+\.(?:com|gov|edu|org)";
string input = @"please send your resumes to adsf@dsf.com apply now!
asdfa@asdf.com/adsf asdf
visit us at sfds@adfa
apply now
follow us on asdf@asdf.gov
asdfa.gov
.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}