import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\w+ ){0,5}\\w+@\\w+\\.(?:com|gov|edu|org)";
final String string = "please send your resumes to adsf@dsf.com apply now!\n"
+ "asdfa@asdf.com/adsf asdf\n"
+ "visit us at sfds@adfa\n"
+ "apply now\n"
+ "follow us on asdf@asdf.gov\n"
+ "asdfa.gov\n"
+ ".com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}