const regex = /(?:\w+ ){0,5}\w+@\w+\.(?:com|gov|edu|org)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\w+ ){0,5}\\w+@\\w+\\.(?:com|gov|edu|org)', 'gm')
const str = `please send your resumes to adsf@dsf.com apply now!
asdfa@asdf.com/adsf asdf
visit us at sfds@adfa
apply now
follow us on asdf@asdf.gov
asdfa.gov
.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}