$re = '/(?:\w+ ){0,5}\w+@\w+\.(?:com|gov|edu|org)/m';
$str = 'please send your resumes to adsf@dsf.com apply now!
asdfa@asdf.com/adsf asdf
visit us at sfds@adfa
apply now
follow us on asdf@asdf.gov
asdfa.gov
.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);