package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\w+ ){0,5}\w+@\w+\.(?:com|gov|edu|org)`)
var str = `please send your resumes to adsf@dsf.com apply now!
asdfa@asdf.com/adsf asdf
visit us at sfds@adfa
apply now
follow us on asdf@asdf.gov
asdfa.gov
.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}