re = /(?:\w+ ){0,5}\w+@\w+\.(?:com|gov|edu|org)/m
str = 'please send your resumes to adsf@dsf.com apply now!
asdfa@asdf.com/adsf asdf
visit us at sfds@adfa
apply now
follow us on asdf@asdf.gov
asdfa.gov
.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end