#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\n{2,}"
Local $sString = "foo" & @CRLF & _
"bar" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Lorem ipsum" & @CRLF & _
"baz" & @CRLF & _
"" & @CRLF & _
"hello world! " & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"done!"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)