const regex = /\n{2,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n{2,}', 'gm')
const str = `foo
bar
Lorem ipsum
baz
hello world!
test
done!`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);