import re
regex = re.compile(r"\n{2,}", flags=re.MULTILINE)
test_str = ("foo\n"
"bar\n\n\n"
"Lorem ipsum\n"
"baz\n\n"
"hello world! \n"
"test\n\n\n"
"done!")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)