import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n{2,}";
final String string = "foo\n"
+ "bar\n\n\n"
+ "Lorem ipsum\n"
+ "baz\n\n"
+ "hello world! \n"
+ "test\n\n\n"
+ "done!";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}