$re = '/\n{2,}/m';
$str = 'foo
bar
Lorem ipsum
baz
hello world!
test
done!';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;