using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n{2,}";
string substitution = @"\n";
string input = @"foo
bar
Lorem ipsum
baz
hello world!
test
done!";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}