# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Technology libraries: )(.*)/\n$1\n$2/gm;t' <<< "Technology libraries: Techlibhellohellohello"