import Foundation
let pattern = #"(Technology libraries: )(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Technology libraries: Techlibhellohellohello"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n$1\n$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)