const regex = new RegExp('(Technology libraries: )(.*)', 'gm')
const str = `Technology libraries: Techlibhellohellohello`;
const subst = `\n$1\n$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);