re = /(Technology libraries: )(.*)/m
str = 'Technology libraries: Techlibhellohellohello'
subst = '\\n$1\\n$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result