use strict;
my $str = 'Technology libraries: Techlibhellohellohello';
my $regex = qr/(Technology libraries: )(.*)/mp;
my $subst = '\\n$1\\n$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";