#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:https?:\/\/[\w\.\-]*)(?:[\w\-]+\/)*(?:[\w\-]+)(?!\/))(\?.*?)?(\#.*?)?$"
Local $sString = "https://my.site.com" & @CRLF & _
"https://my.site.com/" & @CRLF & _
"" & @CRLF & _
"https://my.site.com/about" & @CRLF & _
"https://my.site.com/about/" & @CRLF & _
"" & @CRLF & _
"https://my.site.com/about?query=string" & @CRLF & _
"https://my.site.com/about/?query=string" & @CRLF & _
"" & @CRLF & _
"https://my.site.com/about#TestAnchor" & @CRLF & _
"https://my.site.com/about/#TestAnchor" & @CRLF & _
"" & @CRLF & _
"https://my.site.com/about?query=string#TestAnchor" & @CRLF & _
"https://my.site.com/about/?query=string#TestAnchor" & @CRLF & _
"" & @CRLF & _
"https://my.site.com/about-us" & @CRLF & _
"https://my.site.com/about-us/" & @CRLF & _
"" & @CRLF & _
"https://my.site.com/about/us" & @CRLF & _
"https://my.site.com/about/us/" & @CRLF & _
"" & @CRLF & _
"https://my.site.com/about/us/more/path" & @CRLF & _
"https://my.site.com/about/us/more/path/" & @CRLF & _
"" & @CRLF & _
"https://my.site.com/about/us/more/path?query=string" & @CRLF & _
"https://my.site.com/about/us/more/path/?query=string" & @CRLF & _
"" & @CRLF & _
"https://my.site.com/about/us/more/path#TestAnchor" & @CRLF & _
"https://my.site.com/about/us/more/path/#TestAnchor" & @CRLF & _
"" & @CRLF & _
"https://my.site.com/about/us/more/path?query=string#TestAnchor" & @CRLF & _
"https://my.site.com/about/us/more/path/?query=string#TestAnchor"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")