# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:https?:\/\/[\w\.\-]*)(?:[\w\-]+\/)*(?:[\w\-]+)(?!\/))(\?.*?)?(\#.*?)?$"
test_str = ("https://my.site.com\n"
"https://my.site.com/\n\n"
"https://my.site.com/about\n"
"https://my.site.com/about/\n\n"
"https://my.site.com/about?query=string\n"
"https://my.site.com/about/?query=string\n\n"
"https://my.site.com/about#TestAnchor\n"
"https://my.site.com/about/#TestAnchor\n\n"
"https://my.site.com/about?query=string#TestAnchor\n"
"https://my.site.com/about/?query=string#TestAnchor\n\n"
"https://my.site.com/about-us\n"
"https://my.site.com/about-us/\n\n"
"https://my.site.com/about/us\n"
"https://my.site.com/about/us/\n\n"
"https://my.site.com/about/us/more/path\n"
"https://my.site.com/about/us/more/path/\n\n"
"https://my.site.com/about/us/more/path?query=string\n"
"https://my.site.com/about/us/more/path/?query=string\n\n"
"https://my.site.com/about/us/more/path#TestAnchor\n"
"https://my.site.com/about/us/more/path/#TestAnchor\n\n"
"https://my.site.com/about/us/more/path?query=string#TestAnchor\n"
"https://my.site.com/about/us/more/path/?query=string#TestAnchor")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.