import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:https?:\\/\\/[\\w\\.\\-]*)(?:[\\w\\-]+\\/)*(?:[\\w\\-]+)(?!\\/))(\\?.*?)?(\\#.*?)?$";
final String string = "https://my.site.com\n"
+ "https://my.site.com/\n\n"
+ "https://my.site.com/about\n"
+ "https://my.site.com/about/\n\n"
+ "https://my.site.com/about?query=string\n"
+ "https://my.site.com/about/?query=string\n\n"
+ "https://my.site.com/about#TestAnchor\n"
+ "https://my.site.com/about/#TestAnchor\n\n"
+ "https://my.site.com/about?query=string#TestAnchor\n"
+ "https://my.site.com/about/?query=string#TestAnchor\n\n"
+ "https://my.site.com/about-us\n"
+ "https://my.site.com/about-us/\n\n"
+ "https://my.site.com/about/us\n"
+ "https://my.site.com/about/us/\n\n"
+ "https://my.site.com/about/us/more/path\n"
+ "https://my.site.com/about/us/more/path/\n\n"
+ "https://my.site.com/about/us/more/path?query=string\n"
+ "https://my.site.com/about/us/more/path/?query=string\n\n"
+ "https://my.site.com/about/us/more/path#TestAnchor\n"
+ "https://my.site.com/about/us/more/path/#TestAnchor\n\n"
+ "https://my.site.com/about/us/more/path?query=string#TestAnchor\n"
+ "https://my.site.com/about/us/more/path/?query=string#TestAnchor";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}