$re = '/^((?:https?:\/\/[\w\.\-]*)(?:[\w\-]+\/)*(?:[\w\-]+)(?!\/))(\?.*?)?(\#.*?)?$/m';
$str = 'https://my.site.com
https://my.site.com/
https://my.site.com/about
https://my.site.com/about/
https://my.site.com/about?query=string
https://my.site.com/about/?query=string
https://my.site.com/about#TestAnchor
https://my.site.com/about/#TestAnchor
https://my.site.com/about?query=string#TestAnchor
https://my.site.com/about/?query=string#TestAnchor
https://my.site.com/about-us
https://my.site.com/about-us/
https://my.site.com/about/us
https://my.site.com/about/us/
https://my.site.com/about/us/more/path
https://my.site.com/about/us/more/path/
https://my.site.com/about/us/more/path?query=string
https://my.site.com/about/us/more/path/?query=string
https://my.site.com/about/us/more/path#TestAnchor
https://my.site.com/about/us/more/path/#TestAnchor
https://my.site.com/about/us/more/path?query=string#TestAnchor
https://my.site.com/about/us/more/path/?query=string#TestAnchor';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);