re = /^((?:https?:\/\/[\w\.\-]*)(?:[\w\-]+\/)*(?:[\w\-]+)(?!\/))(\?.*?)?(\#.*?)?$/m
str = 'https://my.site.com
https://my.site.com/
https://my.site.com/about
https://my.site.com/about/
https://my.site.com/about?query=string
https://my.site.com/about/?query=string
https://my.site.com/about#TestAnchor
https://my.site.com/about/#TestAnchor
https://my.site.com/about?query=string#TestAnchor
https://my.site.com/about/?query=string#TestAnchor
https://my.site.com/about-us
https://my.site.com/about-us/
https://my.site.com/about/us
https://my.site.com/about/us/
https://my.site.com/about/us/more/path
https://my.site.com/about/us/more/path/
https://my.site.com/about/us/more/path?query=string
https://my.site.com/about/us/more/path/?query=string
https://my.site.com/about/us/more/path#TestAnchor
https://my.site.com/about/us/more/path/#TestAnchor
https://my.site.com/about/us/more/path?query=string#TestAnchor
https://my.site.com/about/us/more/path/?query=string#TestAnchor'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end