import re
regex = re.compile(r"(https{0,1}:\/\/)", flags=re.MULTILINE)
test_str = ("https://regex101.com\n"
"https://stackoverflow.com/questions/57601242/why-is-this-regex-expression-not-matching-the-string-exactly\n"
"http://www.regular-expressions.info/optional.html\n"
"https://www.youtube.com/watch?v=iA9DlBSMQ4c")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")