re = /(https{0,1}:\/\/)/m
str = 'https://regex101.com
https://stackoverflow.com/questions/57601242/why-is-this-regex-expression-not-matching-the-string-exactly
http://www.regular-expressions.info/optional.html
https://www.youtube.com/watch?v=iA9DlBSMQ4c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end