// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https{0,1}:\/\/)").unwrap();
let string = "https://regex101.com
https://stackoverflow.com/questions/57601242/why-is-this-regex-expression-not-matching-the-string-exactly
http://www.regular-expressions.info/optional.html
https://www.youtube.com/watch?v=iA9DlBSMQ4c";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}