#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(api|f)(\d{0,3})?\.backblazeb2\.com(\/.*)?"
Local $sString = "api.backblazeb2.com" & @CRLF & _
"api000.backblazeb2.com" & @CRLF & _
"api001.backblazeb2.com " & @CRLF & _
"api002.backblazeb2.com" & @CRLF & _
"api003.backblazeb2.com" & @CRLF & _
"api004.backblazeb2.com" & @CRLF & _
"api005.backblazeb2.com" & @CRLF & _
"f000.backblazeb2.com" & @CRLF & _
"f001.backblazeb2.com" & @CRLF & _
"f002.backblazeb2.com" & @CRLF & _
"f003.backblazeb2.com" & @CRLF & _
"f004.backblazeb2.com" & @CRLF & _
"f005.backblazeb2.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")