import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(api|f)(\\d{0,3})?\\.backblazeb2\\.com(\\/.*)?";
final String string = "api.backblazeb2.com\n"
+ "api000.backblazeb2.com\n"
+ "api001.backblazeb2.com \n"
+ "api002.backblazeb2.com\n"
+ "api003.backblazeb2.com\n"
+ "api004.backblazeb2.com\n"
+ "api005.backblazeb2.com\n"
+ "f000.backblazeb2.com\n"
+ "f001.backblazeb2.com\n"
+ "f002.backblazeb2.com\n"
+ "f003.backblazeb2.com\n"
+ "f004.backblazeb2.com\n"
+ "f005.backblazeb2.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}