const regex = /^(api|f)(\d{0,3})?\.backblazeb2\.com(\/.*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(api|f)(\\d{0,3})?\\.backblazeb2\\.com(\\\/.*)?', 'gm')
const str = `api.backblazeb2.com
api000.backblazeb2.com
api001.backblazeb2.com
api002.backblazeb2.com
api003.backblazeb2.com
api004.backblazeb2.com
api005.backblazeb2.com
f000.backblazeb2.com
f001.backblazeb2.com
f002.backblazeb2.com
f003.backblazeb2.com
f004.backblazeb2.com
f005.backblazeb2.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}