use strict;
my $str = 'api.backblazeb2.com
api000.backblazeb2.com
api001.backblazeb2.com
api002.backblazeb2.com
api003.backblazeb2.com
api004.backblazeb2.com
api005.backblazeb2.com
f000.backblazeb2.com
f001.backblazeb2.com
f002.backblazeb2.com
f003.backblazeb2.com
f004.backblazeb2.com
f005.backblazeb2.com';
my $regex = qr/^(api|f)(\d{0,3})?\.backblazeb2\.com(\/.*)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}