re = /^(api|f)(\d{0,3})?\.backblazeb2\.com(\/.*)?/m
str = 'api.backblazeb2.com
api000.backblazeb2.com
api001.backblazeb2.com
api002.backblazeb2.com
api003.backblazeb2.com
api004.backblazeb2.com
api005.backblazeb2.com
f000.backblazeb2.com
f001.backblazeb2.com
f002.backblazeb2.com
f003.backblazeb2.com
f004.backblazeb2.com
f005.backblazeb2.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end