// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(api|f)(\d{0,3})?\.backblazeb2\.com(\/.*)?").unwrap();
let string = "api.backblazeb2.com
api000.backblazeb2.com
api001.backblazeb2.com
api002.backblazeb2.com
api003.backblazeb2.com
api004.backblazeb2.com
api005.backblazeb2.com
f000.backblazeb2.com
f001.backblazeb2.com
f002.backblazeb2.com
f003.backblazeb2.com
f004.backblazeb2.com
f005.backblazeb2.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}