import re
regex = re.compile(r"^(api|f)(\d{0,3})?\.backblazeb2\.com(\/.*)?", flags=re.MULTILINE)
test_str = ("api.backblazeb2.com\n"
"api000.backblazeb2.com\n"
"api001.backblazeb2.com \n"
"api002.backblazeb2.com\n"
"api003.backblazeb2.com\n"
"api004.backblazeb2.com\n"
"api005.backblazeb2.com\n"
"f000.backblazeb2.com\n"
"f001.backblazeb2.com\n"
"f002.backblazeb2.com\n"
"f003.backblazeb2.com\n"
"f004.backblazeb2.com\n"
"f005.backblazeb2.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")