# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/?(\w+)(?=(?:\/\w+)+metastase\b)\/?/$1metastase /gm;t' <<< "lever/botmetastase
kidney/lever/botmetastase
pancreas/kidney/lever/botmetastase
"